LEDE und FF-GT

(Daniel) #1

Guten Morgen zusammen,

ich habe hier einen TL-1043ND V4 und habe LEDE darauf laufen 17.01.01 also die aktuellste Version. Nun habe ich auch ein Gastnetz auf dem Router welches ich gerne über FF-GT ins Internet “verklappen” würde. Nun ist es ja so das der opkg einige Pakete bereit hält die Freifunk betreffen …

Ist es möglich nicht die FF-GT Firmware zu nutzen sondern die Einstellungen mit dem in LEDE oder OpenWRT Paketen selber auf nem Router zusammen zu bauen ? Die FF-GT Firmware würde sonst ein eigenes Gerät bedeuten was ich verhindern möchte.

Viele Grüße,
Daniel

0 Likes

(Kai 'wusel' Siering) #2

Puhh. Unser Freifunk-Netz basiert auf B.A.T.M.A.N. Advanced (batman-adv) in »Kompatibilitätsversion« v14 (aus 2013); badman-adv v15 ist nicht kompatibel (erst ab v15 sollen zukünftige Versionen abwärtskompatibel sein), das wäre also die erste Hürde: ein badman-adv-v14 -Kernelmodul für LEDE. Dann nutzen wir für die Anbindung zu den Gateways fastd als Tunneltechnologie., das sollte es für LEDE auch geben. Und dann muß das nur noch richtig zusammengeknotet werden und im Grunde sollte es gehen.

root@33332-Testknoten-81ec:~# brctl show
bridge name     bridge id               STP enabled     interfaces
br-client               7fff.e894f69081ec       no              eth0
                                                        client0
                                                        bat0
br-wan          7fff.e894f69081ed       no              eth1
root@33332-Testknoten-81ec:~# batctl if
primary0: active
mesh-vpn: active
ibss0: active

Gut, ohne A.L.F.R.E.D.-Daemon, der im richtigen Format Infos ins Freifunk-Netz schickt, würde Dein Freifunk-Knoten nicht in der Karte auftauchen, aber funktionieren könnte es.

Gluon ist »nichts weiter« als ein Framework, auf OpenWRT (ab v2017.1, yet to be released: LEDE) aufsetzend Freifunk-Knoten standardisiert einfach per Weboberfläche zu konfigurieren und im Betrieb ein bißchen Statistik zu verteilen, die dann mit entsprechenden Tools in mehr oder weniger Eye-Candy verwandelt werden können.

That said, die aktuell in ersten Tests befindliche 0.7.9er Firmware (wenn fertig, wird sie 0.8.0 heißen) unterstützt u. a. auch den 1043ND v4 und bietet weiterhin die Möglichkeit, das für den Uplink benutzte Netz als privates WLAN WPA-verschlüsselt auszustrahlen.

Aber prinzipiell geht das, ja …

0 Likes

(Daniel) #3

Hab es hinbekommen einfach fastd und batman-adv installieren und dann noch die Config aus dem Github reinpacken und die Interface reinpacken und geht. Alfred wäre schön aber das ist mir zuviel Drama :wink: Danke Wusel

0 Likes

(Kai 'wusel' Siering) #4

Hab es hinbekommen einfach fastd und batman-adv installieren und dann noch die Config aus dem Github und löft.

Cool :wink:

0 Likes

(Daniel) #5

Nutzt du noch OpenWRT als Basis wusel ? Laut den Bielefeldern läuft es wohl mit LEDE ganz gut, jedoch das meshen über den wifi Adapter bei manchen Modellen noch nicht …

… und Netflix läuft nicht über FF … weil das ja ein ganz ganz böser Tunnel ist über den ich da komme … Käse

0 Likes

(Kai 'wusel' Siering) #6

Wir nutzen das Gluon-Framework, AFAIK sind zumindest einige der Entwickler auch stark bei OpenWRT und nun LEDE involviert. Gluon v2016 basiert auf OpenWRT CC mit Backports aus LEDE, v2017 soll auf LEDE fußen. Wechseln werden wir wohl nicht komplett, eher nur neue Geräte dann unter einer 0.9er-FW-Nummer mit LEDE bedienen. Und schon die Probleme mit einigen WLAN-Treibern in OpenWRT CC haben dazu geführt, daß einige Communities – neben uns u. a. auch Hamburg – erst jetzt auf Gluon v2016.2.4/.5 gehen, erst mit dem vor ein paar Wochen alten Release scheint die Stabilität wieder auf BB-Niveau zu sein :frowning:

Wer will, kann ja auf Basis von LEDE sich ins Netz klemmen (siehe Dein Beispiel, im Grunde ist es kein Hexebwerk), für die Masse der ‘tolle Idee, ich kann “make” aber nur buchstabieren, wie kann ich dennoch mitmachen’-Teilnehmer ist eine getestete und sich selbst aktualisierende Firmware/Distribution praktischer :slight_smile:

1 Like

(Kai 'wusel' Siering) #7

Hmm, seinerzeit (~6 Monate her) in B habe ich via FFGT an VDSL50 auch Prime & Netflix geguckt … War keine Absicht, vergessen, lokales WLAN zu konfigurieren :slight_smile:

0 Likes

(Daniel) #8

Hey Wusel …

bin gerade dabei nochmals das FFGT auf einem 1043V1 mit Lede ans laufen zu bekommen, bin mir aber nicht mehr sicher welche Parts ich aus der Konfig brauche um den batman_adv und fastd zu konfigurieren …

Ist schon alles so lange her -.-

0 Likes

(Daniel) #9

Bei den Bielefeldern kann ich die Knotenconfig für batman_adv und fastd finden … im FFGT Github nicht

0 Likes

(Kai 'wusel' Siering) #10

site.conf & site.mk ist in site-ffgt (IIRC), da stehen auch Port (10000), MTU (Achtung, gepushte MTU ist für nächstes Release (kompatibel mit DS-Lite)! Commit checken!), GW-Namen & -Keys drin. batman_adv muß v14 sein (siehe site.mk), that’s it.

0 Likes

(Daniel) #11

Könntest du mir einfach den Part aus der fastd config in /etc/config/fastd geben oder die ganze Datei von einem laufenden Gerät ? Das wäre einfacher :wink:

0 Likes

(Kai 'wusel' Siering) #13
# cat /etc/config/fastd

config fastd 'sample_config'
        option enabled '0'
        option syslog_level 'info'
        list method 'salsa2012+umac'
        option mode 'tap'
        option interface 'tap0'
        option mtu '1426'
        option forward '0'
        option secure_handshakes '1'

config peer 'sample_peer'
        option enabled '0'
        option net 'sample_config'
        option key '0000000000000000000000000000000000000000000000000000000000000000'

config peer_group 'sample_group'
        option enabled '0'
        option net 'sample_config'

config fastd 'mesh_vpn'
        option enabled '1'
        option mtu '1426'
        option group 'gluon-fastd'
        option status_socket '/var/run/fastd.mesh_vpn.socket'
        option packet_mark '1'
        option syslog_level 'verbose'
        option mode 'tap'
        option secure_handshakes '1'
        option interface 'mesh-vpn'
        option secret 'xxx'
        list method 'salsa2012+umac'

config peer_group 'mesh_vpn_event'
        option enabled '1'
        option peer_limit '1'
        option net 'mesh_vpn'

config peer 'mesh_vpn_event_peer_event01'
        option enabled '1'
        option key '21630f3eec4c38808b93947a5ac2f5eae39538b47e9225513bd2b2fa27c4593a'
        option net 'mesh_vpn'
        list remote '"gw-event01.4830.org" port 10000'
        option group 'mesh_vpn_event'

config peer 'mesh_vpn_event_peer_event02'
        option enabled '1'
        option key 'e54a099a3967e2eae0a5e9afc4048adea0f5a7051bfc37616748797c76df77ac'
        option net 'mesh_vpn'
        list remote '"gw-event02.4830.org" port 10000'
        option group 'mesh_vpn_event'

config peer 'mesh_vpn_event_peer_test01'
        option enabled '1'
        option key '3d994652d67cc7a2b4d18cc852d450cd78bfdc50c2c3a8c6ed7df18591c033b3'
        option net 'mesh_vpn'
        list remote '"gw-test01.4830.org" port 10000'
        option group 'mesh_vpn_event'

config peer_group 'mesh_vpn_backbone'
        option enabled '1'
        option peer_limit '1'
        option net 'mesh_vpn'

config peer 'mesh_vpn_backbone_peer_gw03'
        option enabled '1'
        option key '40343e165e102f65513b5ddb2eb855289fc2e353af672fbe8924627acc2bf8ce'
        option net 'mesh_vpn'
        list remote '"gw03-neu.4830.org" port 10000'
        option group 'mesh_vpn_backbone'

config peer 'mesh_vpn_backbone_peer_gw06'
        option enabled '1'
        option key 'be56eb2cb9493f22b6e0cce4c7f8c838fd44e8c44c6983c58265bbe1c2cf04c0'
        option net 'mesh_vpn'
        list remote '"gw06.4830.org" port 10000'
        option group 'mesh_vpn_backbone'

config peer 'mesh_vpn_backbone_peer_gw01'
        option enabled '1'
        option key '2ddba2fe0ed61615016cbbbd71ca1afcc7432dd8eb81c1e18806bcbb766b72b3'
        option net 'mesh_vpn'
        list remote '"gw01-neu.4830.org" port 10000'
        option group 'mesh_vpn_backbone'

config peer 'mesh_vpn_backbone_peer_gw02'
        option enabled '1'
        option key 'ee0902a7452d017cd154005e10944dcb278d648776988922d52b960e05d49780'
        option net 'mesh_vpn'
        list remote '"gw02-neu.4830.org" port 10000'
        option group 'mesh_vpn_backbone'

config peer 'mesh_vpn_backbone_peer_gw05'
        option enabled '1'
        option key '7f94344fa80d5ec144c14db366712a0cf34f420571cbe4e1025a3f23a88474cb'
        option net 'mesh_vpn'
        list remote '"gw05.4830.org" port 10000'
        option group 'mesh_vpn_backbone'

config peer 'mesh_vpn_backbone_peer_gw04'
        option enabled '1'
        option key '82532813585cba2538498df56869a57865fe8fa271c4eb61a9e4831310efbdcd'
        option net 'mesh_vpn'
        list remote '"gw04-neu.4830.org" port 10000'
        option group 'mesh_vpn_backbone'
0 Likes

(Daniel) #14

… das klappt nicht, wie ist der Key genau ? Wenn ich den fastd starte heult der an der Stelle rum das der Key invalid wäre

0 Likes

(Kai 'wusel' Siering) #15

Kerl! Natürlich mußte Du einen eigenen erzeugen und dort eintragen :slight_smile: Im Gegenteil: zwei identische Secretkeys in einem fastd -> beide Verbindungen werden gekickt. Daher niemals fastd-Keys recyclen …

0 Likes

(Daniel) #16

Ja ok ok … ich hab nun mit dem fastd nen secret generiert und eingetragen nun kommt der fastd hoch aber das DHCP zieht keine Adressen scheinbar -.-

MTU 1426 im Interface umd fastd passt ?

0 Likes

(Kai 'wusel' Siering) #17

dmesg | grep batman gibt was?

0 Likes

(Daniel) #18

[ 2536.082378] batman_adv: bat0: The MTU of interface fastd_mesh is too small (1460) to handle the transport of batman-adv packets. Packets going over this interface will be fragmented on layer2 which could impact the performance. Setting the MTU to 1532 would solve the problem.
[ 2536.107027] batman_adv: bat0: Interface activated: fastd_mesh
[ 2594.003322] batman_adv: bat0: Interface deactivated: fastd_mesh
[ 2594.076435] batman_adv: bat0: Removing interface: fastd_mesh
[ 2596.949932] batman_adv: bat0: Adding interface: fastd_mesh
[ 2596.955578] batman_adv: bat0: Interface activated: fastd_mesh

logread das:
Sat Nov 4 14:55:05 2017 daemon.warn fastd[3810]: Handshake with [hidden]:10000 failed: sending error: MTU configuration differs with peer (local MTU is 1532)

bei den Bielefeldern hat das fastd_mesh und der deamon beide 1406 als MTU was auch tadellos funktioniert

0 Likes

(Daniel) #19

Nun beides auf 1426 gestellt:
[ 3342.270917] batman_adv: bat0: Interface activated: fastd_mesh
[ 3342.729348] batman_adv: bat0: No IGMP Querier present - multicast optimizations disabled
[ 3342.737503] batman_adv: bat0: No MLD Querier present - multicast optimizations disabled
[ 3344.399141] batman_adv: bat0: Changing gw mode from: off to: client
[ 3344.490478] batman_adv: bat0: orig_interval: Changing from: 1000 to: 10000
[ 3393.768274] batman_adv: bat0: Interface deactivated: fastd_mesh
[ 3393.806627] batman_adv: bat0: Removing interface: fastd_mesh
[ 3396.763933] batman_adv: bat0: Adding interface: fastd_mesh
[ 3396.769545] batman_adv: bat0: The MTU of interface fastd_mesh is too small (1426) to handle the transport of batman-adv packets. Packets going over this interface will be fragmented on layer2 which could impact the performance. Setting the MTU to 1532 would solve the problem.
[ 3396.794143] batman_adv: bat0: Interface activated: fastd_mesh

…aber DHCP geht eben nicht obwohl auf dem fastd mächtig Traffic einläuft (1 MB/min ca.) aber nichts rausgeht

0 Likes

(Kai 'wusel' Siering) #20

Ich brauche die compat. version (sprich: Router zu lange online, Info ist aus Ringbuffer schon raus). Vermute, Du hast nicht v14, daher tut das nicht.

Magie gibt’s sonst keine, fastd-IF in br-lan, br-lan per batctl if add in bat0, done (IIRC).

Yepp, “Ad-hoc Netz mit der ESSID mesh_v15 (die Zahl ist die Kompatibilitätsversion von batman) zum Vernetzen der Nodes”, BI nutzt batman_adv v15, das kann nicht funktionieren:

0 Likes

(Kai 'wusel' Siering) #21

Hä?

Gleiche Kerbe wie bei der batman-Version: mit falschen Parametern tut’s nicht. Wozu suche ich Dir die Daten raus (ist alles öffentlich) und dann wird’s dennoch ignoriert? Komme mir ein bißchen veralbert vor.

0 Likes