Firmware reflashen auf WR1043ND V4

Tach Gemeinde!
Mal ne blöde Frage. Da ich auf der GT Seite keine aktuelle stable für den WR1043ND V4 gefunden habe, hab ich Depp eine aus einem anderen Freifunknetz geflasht.
Okok … blöde Idee.
Gibt es die Möglichkeit diese nun via Webinterface so zu bearbeiten das sie auch im hiesigen Netz funktioniert? Einfaches überflashen mit der hiesigen rawhide bzw. Originalfirmware geht leider nicht.
Oder als Plan B … kann jemand der Freaks hier das Ding wieder via TFTP in den Originalzustand versetzen?
Oder doch besser Plan C … das Ding ins Fremdnetz verkaufen? :slight_smile:

cheers Micha

Ein bißchen, ja :wink: Ggf. kurz hier 'n Posting absetzen, welche »rawhide« denn vielleicht schon nutzbar wäre, hätte Dir den folgenden Streß erspart, denn …

… wir arbeiten ja dran :wink:

0.7.9~114 sollte gehen (vgl. http://map.4830.org/ffgt/meshflix/#!v:m;n:106f3f872c2c), ich werde heute abend einen „Factory-Flash“ damit an einem 1043NDv4 und einem 842Nv3 probieren :wink:

Wieso nicht? Wenn das eine OpenWRT-basierte FW ist, sollte "cd /tmp; wget http://firmware.4830.org/rawhide/sysupgrade/gluon-ffgt-0.7.9~114-tp-link-tl-wr1043n-nd-v4-sysupgrade.bin ; sysupgrade -n gluon-ffgt-0.7.9~114-tp-link-tl-wr1043n-nd-v4-sysupgrade.bin " funktionieren. Bei LEDE-basierter Ausgangsfirmware muß ich passen, keine Ahnung, ob/wie ein Downgrade auf OpenWRT möglich ist. Im Zweifel wirst Du wieder auf die TP-Link-FW zurück müssen, um unsere FW zu installieren.

Naja … zu mehr als flashen via Webinterface reicht mein Können dann doch nicht aus … zumal das o.g. Vorgehen ja nur via Linux möglich ist, odr.??? Ich hab derzeit leider echt weder Zeit noch Muße mich da reinzufuchsen.
Wie gesagt … falls mir jemand aus dem raum GT das Ding wenigstens auf Originalfirmware zurücksetzen könnte wäre mir echt schon geholfen. Den Rest schaff ich dann wieder selbst :grinning:

“putty.exe” kann auch von Windows aus ssh sprechen, “connectbot”/“JuiceSSH” von Androiden :wink:

Welche Firmware hast Du denn geflasht und welche Meldung kommt beim Versuch, über die Oberfläche das ffgt-rawhide-sysupgrade-Image zu flashen?

Ah ok …dann probiere ich das mal aus … in der Hoffnung das ich nicht vollends bricke :slight_smile:
Meldung wie bei der Originalfirmware … “falsche Firmware”

Warum antworten Leute auf diese einfache Frage eigentlich nie? »Welche Firmware hast Du denn geflash?« ist imho nicht ehrrührig, und mit dem Wissen müßte man weniger raten :wink:

Hehe … weil sie sie überlesen haben.

Freifunk Ortenau – gluon-ffog-0.3.0~stable20170217-tp-link-tl-wr1043n-nd-v4.bin

Und JA … jetzt weiss ich auch das die Firmwares aus unterschiedlichen Freifunknetzen nicht untereinander austauschbar bzw. anpassbar sind.

Und nochmal JA … die hiesige rawhide hatte ich gesehen … aber es wird ja davon abgeraten bzw. nicht empfohlen sie zu nutzen :slight_smile:

Hmm, das sollte lt. site.mk (“DEFAULT_GLUON_CHECKOUT := v2016.2.3”) dann ein OpenWRT-Gluon sein, d. h. im Config-Mode per Firmwareupgrade-Seite sollte eigentlich das sysupgrade (nicht: factory) sich flashen lassen; auf jeden Fall nicht vergessen, den “Konfigurationsübernahme-Knopf” richtig zu setzen: es darf keine Konfiguration des ffog-Gluons ins ffgt-Gluon übernommen werden.

Ja, vor rawhide ist zu warnen, denn das fällt wirklich so aus dem Image-Erzeugungs-Prozeß raus und hat immer mal wieder gravierende Bugs. Aber es gibt auch immer mal wieder Versionen, die leidlich funktional sind (und sich dann später auf einen stable o. ä. per Autoupdater aktualisieren würden).

Kurzum: bevor “fremde” Firmwares ausprobiert werden, einfach mal lokal fragen :wink:

Ciao,
-kai

nope … llässt sich nicht flashen. Gleiche Meldung wie beim Versuch ne Originale aufzuspielen.
Lt. diverser Foren hilft wohl nur die Nummer per TFTP zu machen.

Anyway … hatte gehofft das das hier jemand “auf die Schnelle” bügeln kann :slight_smile:
Werd mal sehen das ich irgendwann Zeit finde mich da reinzuwuseln.

Die Gäste sollen auch lieber Bier trinken anstatt rumzusurfen :sunglasses:

cheers Micha

Btw. Die ehemalige Möglichkeit einen vorkonfigurierten Router zu kaufen war schon ziemlich cool. Einstecken, kurz einrichten und fertig. Könnte man mal wieder einführen :slight_smile:

Das ist aber schon sonderbar; in dem Fall würde ja das bei uns auch nicht funktionieren :frowning: Ich kann mir den gerne mal angucken, tftp und Linux sind für mich eigentlich keine so großen Hürden :wink:

Das mit dem vorkonfigurierten Router kaufen ist leider nicht ganz so einfach, hat rechtliche und organisatorische Haken und Ösen, auch im Hinblick auf den doch eher geringen Durchsatz an Geräten.

Läuft :slight_smile:
Meine 1. Idee war es die Erstinstallationsfirmware drüber zu blasen, was bekanntlich fehl schlug.
Hab es nun mit der Upgradeversion versucht und siehe da … er ist im Netz :slight_smile:

Dein Hinweis auf das Sysupgrade hat die Lampe bei mir aufblitzen lassen :+1:

Jetzt bitte nur noch schnell eine „stable“

cheers Micha

=> so ein kleines bißchen hektisch warste aber auch :slight_smile: Ok, etwas unfair, weil mir ‘natürlich’ klar ist, daß die Images unterschiedlich sind und auch unterschiedlich zu nutzen sind. Wobei, daß das Factory-Image nur für das 1. Flashen auf OpenWRT/Gluon da ist, steht IIRC auch auf der FW-Seite :slight_smile:

Anyway, ich freue mich auf ein Bier mit Freifunk — schön, daß es noch geklappt hat :slight_smile: Und danke für die Rückmeldung, denn ich bekam schon Zweifel; wenn sysupgrade-Image per Web nicht täte, würde auch Auto-Update nicht funktionieren … Uff :slight_smile:

Najaaaaa … so hektisch nun auch wieder nicht. :slight_smile:
Es war ja erst eine "Fremd"Freifunkfirmware drauf … daher die Idee eine frische, neue "Heimat"Freifunkfirmwware draufzublasen.
Kann ja kein Nichtkenner ahnen das zwar die Freifunkfirmwares nicht unbedingt untereinander kompatibel sind, es aber dann doch möglich ist es via Sysupgrade zu richten.
Aber egal … läuft … wobei ich allerdings vorhin noch festgestellt habe, das, wenn ich z.B. in Router1 eingeloggt bin und mich dann in Richtung Router2 bewege nicht unbedingt auf diesen umgeswitcht wird obwohl er ein besseres Signal sendet. Solange ich auch noch nur 1 Balken von Router1 empfange bleibt er dort eingeloggt. Erst nachdem ich mich aus- und dann wieder einlogge nimmt er den Router mit mehr Balken.
Aber das ist jetzt wohl eher ein Luxusproblem :slight_smile:

Danke nochmals :slight_smile:

Nunja, das funktioniert ja auch prinzipiell, wenn man das sysupgrade-Image verwendet. Gibt es Verbesserungsvorschläge zu dem folgenden Text auf der Firmware-Seite?

Noch ein Wort zu den beiden unterschiedlichen Firmware-Versionen: das Factory-Image benötigt man, um einen Router von der Herstellerfirmware auf die Freifunk-Firmare zu bringen. Das sysupgrade-Image wird normalerweise vom sog. Autoupdate-Prozeß auf den mit der Freifunk-Firmware ausgestatteten Routern geladen und somit die Freifunk-Firmware auf dem Gerät aktuell gehalten. Wem das alles nichts sagt, der frage lieber vorher nach :wink:

Änderungsvorschläge gerne genommen; es ist durchaus nicht einfach, Texte zu schreiben, die sich an jemanden ohne Hintergrundwissen richten, wenn einem selber alles sonnenklar ist …

Ja, das ist wohl teilweise so; an sich sollte AFAIK ein Gerät von sich aus zum stärkeren AP mit der gleichen SSID wechseln, praktisch ist dem wohl nicht immer so. Falls wir das beeinflussen können, werden wir das in Zukunft sicherlich tun, aber derzeit ist das in der Tat eher ein Luxusproblem :wink:

D.h. wir müssen uns nicht mehr direkt an den Spielplatz setzen um Empfang zu haben :grin:

Hehe … nope :slight_smile:
Grad in der hintersten Ecke getestet.

1 Like

Btw. … gibt es denn schon eine Idee wann mit einer “stable” für den V4 zu rechnen ist?

Ideen gibt’s viele, »nach Ostern« war der Plan, »vor Pfingsten« wird’s wohl nichts mehr, Wetter und so … :wink:

Die aktuelle FW hat noch einen Bug im Config-Mode (»Netzwerk«-Tab auf echtem Gerät wirft Fehler, wie ich heute morgen sah), dann stehen noch Tests a) der Offline-SSID-Geschichte und b) des WiFi-Fallback-Autoupdaters aus (letzteres mindestens soweit, daß es nix karpott macht ;)). Dann kommt die FW nach experimental (~1 Tag) und danach testing. Nach testing würde ich rd. 'ne Wochen warten wollen, ob irgendwas grob schief läuft, und dann wird die FW nocheinmal neu gebacken als 0.8.0 und von rawide, experimental und testing einen Tag später schließlich zur stable aufgewertet.

Was ist denn der Hintergrund der Frage, einfach nur das ungute Gefühl, eine instabile FW laufen zu lassen? :wink:

Ne … allet jut … läuft ja :slight_smile:
Will nur nicht das irgendein Gast mal rumheult das nix geht und ich nicht weiß warum :grinning:
Aber hat ja auch ein Gutes … sag ich halt “Sch… Freifunkfirmware” … und bin aus der Nummer raus :smiling_imp:

Genau :slight_smile: