Firmware 1.0 und LAN auf "gelb"

(René) #1

Hmm. Ich bekomme mein Lan nicht mehr auf die Lan Ports des Routers. Dort liegt immer FF an.

uci set network.wan.ifname='eth0 eth1'
uci commit network

Wenn ich mit set nachschaue, ist dort auch eth0 und 1 eingetragen. Die Änderungen für das zusätzliche interne Wifi funktionieren. Hat sich da etwas geändert im vergleich zum alten Gluon?
Die Anleitung im Wiki (https://github.com/freifunk-gluon/gluon/wiki/Commandline-administration) hat leider auch nicht funktioniert.

Habe jetzt noch einmal frisch geflashed. Dann sieht es so aus:

network.client.ifname='bat0' 'eth0' 'local-port'
network.wan.ifname='eth1'

Um nun Lan auf auf die Lan Ports zu gekommen müsste ich eth0 von client nach wan schieben, richtig?

0 Likes

Update bzgl. Firmware 1.0
(Cord) #2

Oh. hier auch.

0 Likes

(René) #3

Das LAN wieder auf die Lan Ports zu bekommen ist doch einfach.

  1. Aktuelle config anschauen

     network.client.ifname='bat0' 'eth0' 'local-port'
     network.wan.ifname='eth1'
    
  2. eth0 von client auf wan umziehen

    uci del_list network.client.ifname='eth0'
    uci add_list network.wan.ifname='eth0'
    uci commit

  3. Netzwerk neu starten.

    /etc/init.d/network restart

0 Likes

(Cord) #4

Hmm. hier nicht.

network.bat0.ifname='bat0'
network.client.ifname='bat0'
network.fallback6.ifname='@fallback'
network.local_node.ifname='local-node'
network.loopback.ifname='lo'
network.mesh_lan.ifname='eth0'
network.mesh_vpn.ifname='mesh-vpn'
network.mesh_wan.ifname='br-wan'
network.wan.ifname='eth0' 'eth1'
network.wan6.ifname='br-wan'
simple-tc.example.ifname='eth0'
simple-tc.mesh_vpn.ifname='mesh-vpn'
wireless.client_radio0.ifname='client0'
wireless.ibss_radio0.ifname='ibss0'
0 Likes

(Kai 'wusel' Siering) #5

Hmm, Config-Mode?

0 Likes

(Cord) #6

Nö? Das Ding strahlt munter Kreisgt.freifunk.net aus.

0 Likes

(René) #7


Seit der Änderung kann ich mich nicht mehr mit den Telefon verbinden. Und andere offenbar auch nicht :frowning:

0 Likes

Update bzgl. Firmware 1.0
(Kai 'wusel' Siering) #8

Hmm, da sieht man mal wieder, warum das kein Standard werden wird:

  OS: 17.01-SNAPSHOT, r3981+103-184fe1    FW: 1.0.0~113
  HW: TP-Link TL-WR841N/ND v8
root@33332-FWTest-a0f3c1058b90:~# brctl show
bridge name     bridge id               STP enabled     interfaces
br-wan          7fff.5e71cff94180       no              eth0
br-client               7fff.a0f3c1058b90       no              bat0
                                                        eth1
                                                        local-port
                                                        client0

Mein 841v8 hat also br-client auf eth1, br-wan auf eth0.

Yepp, stimmt, habe die Einträge auch:

root@33332-FWTest-a0f3c1058b90:~# uci show network | grep fall
network.fallback6=interface
network.fallback6.sourcefilter='0'
network.fallback6.ifname='@fallback'
network.fallback6.peerdns='1'
network.fallback6.proto='dhcpv6'
network.fallback=interface
network.fallback.sourcefilter='0'
network.fallback.proto='dhcpv6'
network.fallback.peerdns='1'

Wüßte nicht, was Gluon im Normalmodul mit “Fallback” meint/macht …

0 Likes

(René) #9

Und jetzt geht es wieder. Auch die Map zeigt wieder clients an. Merkwürdig.

0 Likes

(Cord) #10
root@33332-cord-de-1:~# brctl show
bridge name	bridge id		STP enabled	interfaces
br-wan		7fff.eaab93937c48	no		eth0
							            eth1
br-client		7fff.e894f66304a2	no		bat0
							                client0

komisch. jetzt gehts. Ob das nen ARP-Cache auf der Fritzbox war?

0 Likes

(René) #11

Caching könnte eine Erklärung sein. Bei mir ging es ja auch erst nach einige Zeit.

0 Likes

(René) #12

@wusel könntest du auf deiner 4040 einmal bitte brctl show aufrufen? Bei mir sieht es so aus:

bridge name     bridge id               STP enabled     interfaces
br-wan          7fff.72ac8eb62740       no              eth0
                                                        eth1
                                                        wlan1-2
                                                        wlan0-2
br-client               7fff.ccce1e34a86c       no              bat0
                                                        client0
                                                        client1

Ich möchte wieder mein LAN auf den gelben Ports haben. Was auch sonst :wink:

Update: Warten. Dann klappt es auch :slight_smile: Alles gut. Passt gerade mit meiner 4040.

0 Likes

(Kai 'wusel' Siering) #13

Die 4040 ist derzeit aus und im Büro, komm’ ich erst nächste Woche wieder ran.

0 Likes

(René) #14

Alles klar. Danke. Dann beobachte ich diese Woche weiter und am Montag quatschen wir bei einem Ouzo.

0 Likes

(Kai 'wusel' Siering) #15

Der 2. Montag im Januar ist allerdings der 14.01.2019; der kommende Montag ist erst der 07.01. und der 1. Montag des Jahres :wink:

0 Likes